Dark Souls 3 Vulnerability Report

A pinned thread on Reddit warns of a remote code execution vulnerability in Dark Souls 3. This seems like a promotion for the Blue Sentinel security mod for the action/RPG sequel, but the accompanying posts appear to confirm legitimate concerns about the exploit, the bona fides of the poster, and the value of the mod. A recent tweet says the mod is now updated to safeguard against this: "The new Blue Sentinel update is now out which should keep your PC and your information safe." Here's the big picture:
A new remote code execution vulnerability has been discovered that is both severe in nature and easier to execute than previous ones that are patched by blue sentinel. We don't believe it's spreading beyond the person who worked on it but the level of damage it can cause is severe, any code sent can be run. Blue sentinel does not patch this vulnerability yet.