Star Citizen Leaves Some CPUs Behind

Roberts Space Industries announces they are no longer supporting processors without Advanced Vector Extension support in Star Citizen (thanks Tom's Hardware). Thus their space game announced a long time ago in a galaxy far, far away will not support CPUs released prior to 2011::
We wanted to give you a heads up that we'll be updating our minimum system requirements with the update coming to the RSI Launcher tomorrow. Specifically, AVX (Advanced Vector Extensions) CPU technology will be a requirement going forward. It's important to note that only older CPUs don't utilize this technology, and we expect very few of you to be impacted by this change.

AVX technology was introduced with Intel's Sandy Bridge processor and AMD's Bulldozer processor (both released in 2011). This means that processors that pre-date this will no longer be able to effectively launch Star Citizen from the updated launcher.