IL-2 Forgotten Battles Patch

The IL-2 Sturmovik Website now offers downloads of a new version 1.22 patch for IL-2 Forgotten Battles, along with the accompanying new version 1.22 dedicated server for the World War II flight simulator (thanks Frans), as Ubisoft continues to try to incapacitate the internet following the release of the Far Cry demo. Accompanying the downloads is the following warning: "The current version (1.22) is not compatible with the previous builds of the game when playing via network. Both the server and the clients must have appropriate versions of the game (1.22) in order to connect."
View : : :
6.
 
Re: No subject
Jan 21, 2004, 18:18
6.
Re: No subject Jan 21, 2004, 18:18
Jan 21, 2004, 18:18
 
Multiplayer will work with any copy of the game. There isn't any CD key/copy protection nonsense involved.

Date
Subject
Author
1.
Jan 21, 2004Jan 21 2004
2.
Jan 21, 2004Jan 21 2004
3.
Jan 21, 2004Jan 21 2004
4.
Jan 21, 2004Jan 21 2004
5.
Jan 21, 2004Jan 21 2004
 6.
Jan 21, 2004Jan 21 2004
 Re: No subject
7.
Jan 21, 2004Jan 21 2004
8.
Jan 21, 2004Jan 21 2004
9.
Jan 21, 2004Jan 21 2004
10.
Jan 22, 2004Jan 22 2004
11.
Jan 22, 2004Jan 22 2004